Follow

Why doesn’t Angry Birds Space work on my iPod Touch/iPhone 3G?

Angry Birds Space has slightly higher system requirements than our previous games. That’s why we will not be able to make the game run on iPhone 3G, 2nd generation iPods. Additionally, since the 8, 16 and 32GB 3rd generation models have 2nd generation hardware, they will also not be able to run the game.

Was this article helpful?
1 out of 1 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk