What are the requirements for Angry Birds Friends?

The game requires either Android 4.1 (or later), iOS 9.0 (or later), or Amazon Fire OS 4 (or later). The game works best on devices which have more than 512MB of RAM.

Was this article helpful?
74 out of 111 found this helpful
Have more questions? Submit a request


Powered by Zendesk